IRCCD-PLUGIN-LINKS(7) - Miscellaneous Information Manual
links - irccd links plugin
The links is used to analyze links sent on channels. It will load the web page and extract its title on the same channel.
The plugin links is distributed with irccd. To enable it add the following to your plugins section:
[plugins] links = ""
The plugin will automatically fetch web page titles on message that contains either http://something or https://something.
Example of possible output:
markand: http://example.org irccd: Example Domain
The following options are available under the [plugin.links] section:
Timeout in seconds before dropping a request (default: 30).
The links plugin supports the following templates in [templates.links] section:
Message to be written when title has been retrieved successfully. Keywords: channel, nickname, origin, server, title.
As HTML pages are not always correct and not openable with a XML parser, links actually searches for a <title></title> tag using a regular expression. While this is not ideal, it usually works in most situations.
Only a few set of HTML entity characters are converted to the human readable format.
macOS 11.2 - @IRCCD_MAN_DATE@