IRCCDCTL.CONF(5) - File Formats Manual
irccdctl.conf - irccdctl configuration file
The irccdctl utility use the same configuration file syntax and paths, see the manual of irccd.conf file for more information.
Configuration are always stored in dedicated section in the form [name] where name is one of the section defined below and are case-sensitive.
This section defines the global irccdctl parameters.
Enable verbose message (Optional, default: false).
The section socket permit irccdctl to connect to a specific irccd transport, only one must be defined. Just like transports you can connect to Unix or internet sockets.
Connection type, must be set to “ip” or “unix”.
An authentication password (Optional, default: none).
The following options are available for the ip type:
Host to connect.
Try to connect with ipv4 (Optional: default true).
Try to connect with ipv6 (Optional: default true).
The following options are available for the unix type:
The file path to the socket.
The alias section can be used to define custom user commands.
To define an alias, just add a new section named [alias.name] where name is your desired alias name.
Then, add any option you like to execute commands you want. The option name is ignored and serves as auto-documentation only.
[alias.present] say-hello = ( "server-message", "localhost", "#staff", "hello world!" ) warning = ( "server-me", "localhost", "#staff", "is a bot")
This alias present will do:
Send a message on the channel #staff in the server localhost
Send an action emote on the same channel
To use this alias, call irccdctl present.
Sometimes, you want to pass parameters to your alias. The placeholder syntax allows you to define where your command line arguments will be replaced before being sent to irccd.
The syntax uses %n where n is an integer starting from 0.
As you have seen in the present alias example above, the channel and server are hardcoded so the user is not able to use this alias for different channels. Let’s update this alias with placeholders to make it more generic.
[alias.present] say-hello = ( "server-message", "%0", "%1", "hello world!" ) warning = ( "server-me", "%0", "%1", "is a bot")
Now, the present alias will except two arguments from the command line when the user invokes irccdctl as following:
Thus if you want to use this alias on the #staff@localhost, you call the alias using:
irccdctl present localhost "#staff"
Example for internet transports.
[connect] type = "internet" hostname = "localhost" port = "9999"
Example for unix transports.
[connect] type = "unix" path = "/tmp/irccd.sock" # inspired by irssi /cycle [alias.cycle] leave = ( "server-part", "%0", "%1" ) join = ( "server-join", "%0", "%1" )
irccdctl was written by David Demelier <firstname.lastname@example.org>
macOS 11.2 - @IRCCD_MAN_DATE@